This is the desktop Ubuntu needs to run with..