Language Selection

English French German Italian Portuguese Spanish

Sapphire Radeon HD 6950

Filed under
Hardware

Have you been wondering how the AMD Radeon HD 6900 "Cayman" graphics cards are running under Linux? After all, Cayman is quite different from the rest of the Radeon HD 6000 "Northern Island" GPUs and its open-source Linux support came much later. There is no reason to wonder any longer as Sapphire has sent over their Radeon HD 6950 DIRT 3 Special Edition graphics card, which we have now put through our arsenal of tests under Ubuntu Linux.

Specifications:

- Radeon HD 6950 "Cayman" GPU
- 2048MB GDDR5 Video Memory
- 5000MHz Effective Memory Clock / 800MHz Core Clock
- Dual-Link DVI, HDMI, DisplayPort Outputs
- DIRT 3 Special Edition

full story




More in Tux Machines

Second Alpha Build of Liquid Lemur Linux 2.0 Brings LibreOffice 5, Based on Debian 8

Edward Snyder, the creator and maintainer of the Debian-based Liquid Lemur Linux distribution, has announced the release and immediate availability for download of the second Alpha build of the upcoming Liquid Lemur Linux 2.0 distro. Read more

Manjaro Linux 0.8.13.1 Fluxbox Edition Gets Linux Kernel 4.1 LTS, Download Now

The Manjaro Linux team, through Bernhard Landauer, has proudly announced the release of an updated version of the Manjaro Linux Fluxbox Edition, namely 0.8.13.1, which features an updated Linux kernel and numerous improvements. Read more

NVIDIA reveals GPUs for blade servers, Linux desktop support

VMworld 2015 NVIDIA has announced the second version of its Grid desktop virtualisation software, complete with a pair of GPUs for blade servers. NVIDIA is pitching GRID as a hardware offering tuned to the needs of graphically-demanding desktop virtualisation (VDI) workloads. If that sounds a bit exotic, consider environments like the resources industry, where on-site engineers need CAD and modelling tools, but miners are loathe to deploy desktops in the remote sites where stuff gets dug out of the ground. VDI works a treat in such spots. Read more

GNU Linux-libre 4.2-gnu is now available

Many new drivers required cleaning of their blob-requesting-and-loading machinery. Various others needed deblobbing updates due to blob name changes and false positives. Read more Also: