Issues with Thunderbird 1.5

Filed under
Software

As posted on Slashdot, there are some issues with the new Thunderbird 1.5.

The most important: Uninstall your old versions of Thunderbird before running the installer for 1.5. Don't let the installer for 1.5 just overwrite the older version, as it will result in a BROKEN installation! Backup your profiles, uninstall old version, then install 1.5.

This is officially listed under Known Issues:

Issues with Thunderbird 1.5.