Language Selection

English French German Italian Portuguese Spanish

You don't need a computer science degree to work with open source software

Filed under
OSS

I am mostly a self-taught programmer. When I was growing up in the late 1970s, our elementary school had a small resource room with an Apple II computer. My brother and I fell into a group of friends that liked computers, and we all helped each other learn the system.

We showed such promise that our parents bought us an Apple II+ clone called the Franklin ACE 1000. My brother and I taught ourselves how to program in AppleSoft BASIC. Our parents bought us books, and we devoured them. I learned every corner of BASIC by reading about something in the book, then writing a practice program. My favorite pastime was writing simulations and games.

I stayed with BASIC for a long time. Our next computer was an IBM PC clone with a version of BASIC on it. Much later, MS-DOS 5 introduced QBasic, which was a modern version of BASIC that finally eliminated line numbers.

Read more

More in Tux Machines

Plasma and the systemd startup

Landing in master, plasma has an optional new startup method to launch and manage all our KDE/Plasma services via a system --user interface rather than the current boot scripts. This will be available in Plasma 5.21. It is currently opt-in, off by default. I hope to make it the default where available after more testing and feedback, but it is important to stress that the current boot-up method will exist and be supported into the future. A lot of work was put into splitting and tidying so the actual amount of duplication in the end result is quite small and manageable. Read more

today's howtos

Mozilla Thunderbird 78.3 Is Out and You Can Finally Upgrade from Earlier Versions

Mozilla Thunderbird 78.3 open-source and free email client has arrived with more improvements and bug fixes, and you can now finally upgrade from older Thunderbird releases. When Thunderbird 78 launched earlier this year, it didn’t support automatic upgrades from version 68 or earlier. Automatic upgrade was blocked intentionally due to the revamped extension system that only supports MailExtensions, not classic extensions, to no break your Thunderbird installations. Three months later, Mozilla enabled automatic upgrades in Thunderbird with version 78.2.2 released a couple of weeks ago. Now Thunderbird 78.3 is out and it disables the installation of “legacy” MailExtensions. Read more

Android Leftovers